Published

27. Jan 2019

Systemanforderungen

OnGea hat Systemanforderungen auf drei Ebenen:

  1. Anforderungen für einen Server/Webspace mit einem OnGea-System
  2. Anforderungen an Browser, die verwendet werden, um mit dem OnGea System zu arbeiten
  3. Anforderungen an Smartphones für die Ausführung der OnGea Mobile App

1. Voraussetzungen für einen Server/ Webspace, auf dem ein OnGea-System läuft

Das OnGea System verwendet das Open Source CMS Drupal 8 als Systemkern. Um also ein OnGea-System betreiben zu können, muss ein Server/Webspace daher alle Anforderungen an ein Drupal 8-System erfüllen, wie sie unter http://www.drupal.org/docs/8/system-requirement beschrieben sind.

Du brauchst einen funktionierenden Webserver, wie er in XAMPP bereitgestellt wird (https://de.wikipedia.org/wiki/XAMPP), einschließlich:

  • Apache HTTP Server
  • MySQL/ MariaDB Datenbank
  • PHP (Version 7.1.10 oder höher)

OnGea benötigt eine Menge Ressourcen. Stelle sicher, dass Dein Webserver wie folgt konfiguriert ist:

  • mindestens 2,5 Gigabyte freier Festplattenspeicher
  • PHP Version 7.1.10 oder höher, mit
    • image library
    • OpenSSL
    • JSON
    • cURL
    • mbstring (Multibyte String)
    • OPcache
  • PHP FastCGI

In der Datei php.ini müssen folgende Einstellungen vorgenommen werden:

  • max_execution_time = 100
  • memory_limit = 128
  • post_max_size = 64m
  • upload_max_filesize = 64m

2. Anforderungen an Browser, die für die Arbeit mit einem OnGea-System verwendet werden

Wir empfehlen, für das Arbeiten mit einem OnGea-System eine aktuelle Firefox-Version (Version 60 oder neuer) zu verwenden. Die meisten anderen aktuellen Browser sollten auch funktionieren; aber Firefox ist der, den wir am häufigsten zum Testen des Systems verwendet haben. Für den Druck von Exportlisten empfehlen wir Chrome (Version 70 oder neuer), da es eine bessere Druckfunktionalität bietet.

3. Anforderungen an Smartphones für die Ausführung der OnGea Mobile App

Die OnGea Mobile App läuft auf Smartphones mit den Betriebssystemen:

  • Android 5 (oder neuer)
  • iOS 8.0 (oder neuer)

Es benötigt bestimmte Systemberechtigungen, die bei der Installation angegeben werden müssen. Außerdem funktioniert die OnGea Mobile App nur in Verbindung mit einem OnGea-System, das Daten an die App liefert: Benutzer*innen der OnGea Mobile App müssen über ein Benutzer*innenkonto auf diesem OnGea-System verfügen; sie müssen die URL dieses OnGea-Systems und ihre Zugangsdaten für dieses System eingeben, um in die OnGea Mobile App zu gelangen. Und sie müssen bestätigte Teilnehmer*innen mindestens einer Aktivität in diesem OnGea-System sein, um die OnGea Mobile App tatsächlich nutzen zu können.

Foto von der internationalen Börse #YAfQRaV 2018 mit Anbid Zaman, © Almut Elhardt.

Author

admin

like it, share it