Publicado

27. Jan 2019

Requerimientos

OnGea tiene requisitos de sistema en tres niveles:

  1. Requisitos para un servidor/espacio web que ejecuta un sistema OnGea
  2. Requisitos para los navegadores utilizados para trabajar con ese sistema OnGea
  3. Requisitos para que los smartphones ejecuten la aplicación OnGea Mobile App

1. Requisitos para un servidor/espacio web que ejecuta un sistema OnGea

El sistema OnGea utiliza el CMS Drupal 8 de código abierto como núcleo del sistema. Por lo tanto, para ejecutar un sistema OnGea, un servidor/espacio web debe cumplir todos los requisitos de un sistema Drupal 8, que se puede encontrar en http://www.drupal.org/docs/8/system-requirement.

Necesitará un servidor web que funcione tal y como se proporciona en XAMPP (https://en.wikipedia.org/wiki/XAMPP), incluyendo:

  • Servidor HTTP Apache
  • MySQL/ MariaDB Base de datos
  • PHP (versión 7.1.10 o superior)

OnGea necesita muchos recursos. Asegúrese de que su servidor web está configurado de la siguiente manera:

  • Al menos 2,5 gigabytes de espacio libre en el disco duro.
  • Versión 7.1.10 o superior, con
    • librería de imágenes
    • OpenSSL
    • JSON
    • cURL
    • mbstring (Multibyte String)
    • OPcache
  • PHP FastCGI

En el archivo php.ini:

Es necesario realizar los siguientes ajustes

  • max_execution_time = 100
  • límite_de_memoria = 128
  • post_max_size = 64m
  • upload_max_filesize = 64m

2. Requisitos para los navegadores utilizados para trabajar con ese sistema OnGea

Recomendamos usar una versión actual de Firefox (versión 60 o más reciente) cuando trabaje con el sistema OnGea como administrador. La mayoría de los otros navegadores actuales también deberían funcionar, pero Firefox es lo que más utilizamos para probar el sistema. Para la impresión de listas de exportación, recomendamos Chrome (versión 70 o posterior), ya que ofrece una mejor funcionalidad de impresión.

3. Requisitos para que los smartphones ejecuten la aplicación OnGea Mobile App

La aplicación OnGea Mobile se ejecutará en Smartphones con los sistemas operativos:

.

  • Android 5 (o superior)
  • iOS 8.0 (o más nuevo)

Necesita ciertos permisos del sistema que deben darse en la instalación. Además, la aplicación OnGea Mobile sólo funciona en conexión con un sistema OnGea que entrega datos a la aplicación: Los usuarios de la aplicación OnGea Mobile necesitarán tener una cuenta de usuario en ese sistema OnGea; deberán introducir la URL de ese sistema OnGea y sus datos de acceso desde ese sistema para acceder a la aplicación OnGea Mobile. Y deben ser participantes aprobados de al menos una actividad en ese sistema OnGea para poder utilizar realmente la aplicación OnGea Mobile App.

Foto del intercambio internacional #YAfQRaV 2018 con Anbid Zaman, © Almut Elhardt.

Autor

admin

si te gusta, comparte