Publié

27. Jan 2019

Exigences

OnGea a une configuration système requise à trois niveaux :

  1. Exigences pour un serveur/espace web exécutant un système OnGea
  2. Exigences pour les navigateurs utilisés pour travailler avec ce système OnGea
  3. Pré-requis pour que les smartphones puissent exécuter l'application OnGea Mobile App

1. Configuration requise pour un serveur/ espace Web exécutant un système OnGea

Le système OnGea utilise le CMS open source Drupal 8 comme noyau du système. Ainsi, pour exécuter un système OnGea, un serveur/espace web doit remplir toutes les conditions requises pour un système Drupal 8, qui peut être trouvé sur http://www.drupal.org/docs/8/system-requirement.

Vous aurez besoin d'un serveur Web fonctionnel tel qu'il est fourni dans XAMPP (https://en.wikipedia.org/wiki/XAMPP), y compris:

  • Apache HTTP Server
  • Base de données MySQL/ MariaDB
  • PHP (version 7.1.10 ou supérieure)

OnGea nécessite beaucoup de ressources. Assurez-vous que votre serveur web est configuré comme suit:

  • au moins 2,5 gigaoctets d'espace disque libre
  • PHP Version 7.1.10 ou supérieure, avec
    • image library
    • OpenSSL
    • OuvrirSSL
    • JSON
    • cURL
    • mbstring (Multibyte String)
    • OPcache
  • PHP FastCGI

Les réglages suivants doivent être effectués dans le fichier php.ini:

  • temps_d'exécution_max = 100
  • memory_limit = 128
  • taille_post_max_size = 64m
  • upload_max_filesize = 64m

2. Exigences pour les navigateurs utilisés pour travailler avec ce système OnGea

Nous recommandons d'utiliser une version actuelle de Firefox (version 60 ou plus récente) lorsque vous travaillez avec le système OnGea comme administrateur. La plupart des autres navigateurs actuels devraient aussi fonctionner, mais Firefox est ce que nous avons le plus utilisé pour tester le système. Pour l'impression des listes d'exportation, nous recommandons Chrome (version 70 ou plus récente), car il offre une meilleure fonctionnalité d'impression.

3. Conditions requises pour que les Smartphones puissent exécuter l'application OnGea Mobile App

L'application mobile OnGea fonctionnera sur les Smartphones avec les systèmes d'exploitation:

  • Android 5 (ou plus récent)
  • iOS 8.0 (ou plus récent)

Il a besoin de certaines permissions système qui doivent être données à l'installation. De plus, l'application mobile OnGea ne fonctionne qu'en liaison avec un système OnGea qui fournit des données à l'application : Les utilisateurs de l'application mobile OnGea devront disposer d'un compte utilisateur sur ce système OnGea ; ils devront entrer l'URL de ce système OnGea et leurs données de connexion depuis ce système pour accéder à l'application mobile OnGea. Et ils doivent être des participants agréés d'au moins une activité de ce système OnGea pour pouvoir utiliser réellement l'application mobile OnGea App.
Photo de l'échange international #YAfQRaV 2018 avec Anbid Zaman, © Almut Elhardt.

Auteur

admin

like it, share it